Diese Website verwendet Cookies. Wenn Sie die Website weiterverwenden, erklären Sie sich damit einverstanden und akzeptieren außerdem die Datenschutzrichtlinie.

Starke Performance Probleme mit AMD Hardware

Supportbereich für hier angebotene Inhalte.
Antworten
firetuxhx
Beiträge: 1
Registriert: Fr 12. Jul 2019, 10:05

Starke Performance Probleme mit AMD Hardware

Beitrag von firetuxhx » Fr 12. Jul 2019, 13:20

Hallo,
es gibt, auch hier im Forum, natürlich viele Berichte die sich mit der Performancesteigerung in XP11 beschäftigen.
Jedoch wird da nur auf Intel / NVidia Systeme eingegangen und ich finde mich da somit nicht wieder.

Mein Problem ist, dass ich trotz frisch installiertem XP11 ohne Addons oder Scenery Addons mit der Standard Cessna auf einem kleinen Flugplatz (EDVI)
lediglich um die 15 FPS habe. Grafikeinstellungen sind auf mittel. Auflösung FullHD.

Specs:
AsRock X570 Taichi
AMD Ryzen 5 2600 @4GHz OC
16GB RAM @3200MHz
960GB M2 NVMe
8GB Sapphire Vega64 Nitro +
750W Straight Power NT BeQuiet

Andere Spiele, wie bspw Shadow of the Tomb Raider oder auch Division2 rennen mit 70FPS

Ich habe ausschließlich im XP11 diese starken Probleme.

Hat jemand Erfahrungen mit AMD Systemen und XP11 ???
Pauschal das XP11 besser für NVidia optimiert ist, bringt mich nicht weiter ;-) :roll:

cheers
firetux

Benutzeravatar
Agi
Site Admin
Beiträge: 439
Registriert: Sa 29. Apr 2017, 01:42

Re: Starke Performance Probleme mit AMD Hardware

Beitrag von Agi » Fr 12. Jul 2019, 13:42

X-Plane nutzt derzeit noch OpenGL als Grafikschnitstelle und da schneidet deine Grafikkarte (und generell die von AMD) derzeit richtig schlecht ab, verglichen mit vergleichbaren von NVidia. Das wird sich wahrscheinlich nach der Umstellung auf Vulkan ändern, danach sollten AMD-Karten 'normal' performen und keinen nachteil gegenüber denen von NVidia mehr haben. Die CPU sollte hier nun nicht das Problem sein, jedenfalls solltest du mehr als 15 FPS damit erreichen. Du hast wirklich gar keine AddOns installiert? 15 FPS sind verdammt wenig...

Es spielen aber auch deine Einstellungen eine nicht unwesentliche Rolle, da würde ich mal mit folgendem Anfangen:

Bild


Dann hilft es manchmal, den Shadercache sowie die Einstellungen alle zu löschen (die Preferences bitte vorher sichern, alle Einstellungen gehen verloren), das sind diese beiden ordner:

X-Plane 11/Output/preferences
X-Plane 11/Output/shadercache



Außerdem solltest du sicherstellen, dass der Virenscanner eine Ausnahme für das X-Plane-Verzeichnis hat, damit der nicht eventuell irgendwas verlangsamt und dann teste das mal in KSEA (Seattle) und fliege da etwas herum. Wie sehen dann da deine Frameraten aus?

Um wirklich die leistung in X-Plane zu verbessern kommst du meist um Tweaken nicht herum, dazu habe ich ein Tutorial erstellt:

Tutorial Leistungsoptimierung


Falls du damit auch nicht zu besseren Ergebnissen kommst (ich fliege damit bei 60 FPS auf 'nem ollen Intel i7 2600k) sind auch weitergehende Informationen nötig, zB solche, die du im XP-eigenen Leistungsdisplay bekommst (Strg + L-Shift + F). Dort wird dir neben der Framerate auch die Zeit angezeigt, die sowohl die CPU als auch die GPU braucht, um einen Frame zu berechnen, womit sich recht gut arbeiten lässt.


Grüße,

Agi

Antworten